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See the way the Advanced Search for Magento 2 extension works.

Guide for Advanced Search for Magento 2

Let customers conveniently search Magento 2 products by names. Optimize quick search window
according to users’ needs and customize auto-complete popup display to make searching easy-to-
follow.

Enhance search results popup
Add handy tabs to navigate the results
Display popular and recent searches
Customize search window design
Show ‘View All’ link and ‘Add to Cart’ button
Analyze customers’ activity via Search Analytics dashboard
Rest API support
Block spam requests and bot attacks
ADA & WCAG compliant

The Advanced Search extension is read compatible with GraphQL. Now you can expose the data
you need via GraphQL queries. To install the compatibility, please find the 'amasty/module-elastic-
search-graphql' package in composer suggest.
The extension is compatible with Hyvä Theme. You can find the 'amasty/module-xsearch-hyva-
compatibility' package for installing in composer suggest (Note: the compatibility is available as part
of an active product subscription or Support Subscription. For the correct Hyvä compatibility work, the
GraphQL module should also be installed. You can find it in the composer suggest 'amasty/module-
elastic-search-graphql')

Configuration

To configure the extension settings, go to Admin Panel → Stores → Configuration → Amasty
Extensions → Advanced Search.

General Settings

https://advanced-search-m2.magento-demo.amasty.com/women/tops-women/hoodies-and-sweatshirts-women.html
https://amasty.com
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Enable Fullscreen Mode - Set this setting to 'Yes' to enable the fullscreen mode of the
autocomplete popup.

See the example of the fullscreen mode on the frontend:

Popup width (px) - indicates the width of the autocomplete popup window to make it fit in with
other page elements. The recommended value for the horizontal view is 900. To get the vertical view,
please enter 700 and lower.

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:advanced-search:fullscreen-sample.png
https://amasty.com
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Search Field Width - Choose the 'Default' option to keep the original size of the search field during
the searching process or enable the 'Dynamic' (based on popup width).

Please note: that the “Search Field Width” setting doesn't operate the same way on Hyva Theme as
it does on Luma. When you set the “Search Field Width” to “Default”, it affects the “Popup Width
(px)” setting. This occurs because the default field takes up the full width.

Min Characters - specify the minimal number of characters that customers should type in to trigger
the search process. By default, the number is three.

Search Pop-up Delay (seconds) - Reaching minimum number of characters will trigger search after
a set delay. Please use delay value between 0 and 10 seconds. The default value is '0.5'.

Display ‘Search’ Button - Set 'Yes' to display the 'Search' button near the search field.

See how it looks on the frontend (both variants):

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:advanced-search:display-search-button.png
https://amasty.com
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Enable Redirect from 404 to Search Results - If the option is enabled, when navigating to a
broken URL or a non-existing page, a customer will be redirected to the store search results page
instead of the '404 Not Found' page.

Save Search Term - Set 'Yes' to save search term in the bar after going to the search results page.

Custom URL Key for Default Search Results Page - enable to set SEO-friendly short URLs. URL
will look 'search/yellow' instead of 'catalogsearch/results/q=yellow'.

Search Results Page URL Key - specify the URL alias for the search results' page.Please do not use
'catalogsearch' as URL Key value.

Enable Tabs on the Search Result Page - set to 'Yes' to enable the tabs that sort search results by
Category, CMS, and Landing on the search results page.

https://amasty.com
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Enable search results display in product tabs for your Magento 2 search extension. This
feature is available both for the Elastic Search and the Magento 2 Advanced Search
modules

See on the image below how the tabs will look like if other extensions compatible to the Elastic Search
by Amasty are also installed. These two extra tabs on the image become available if the Amasty
Landing Pages for Magento 2 and Amasty Improved Layered Navigation for Magento 2 are installed.
Some other extensions will add other tabs to your Magento quick search tool.

Enable Indexation for Autocomplete popup - Set 'Yes' to speed up autocomplete popup
performance. Please note, the reindex will take longer. This feature comes with the Amasty Elastic
Search extension only.

To ensure smooth operation, it's important to run a reindexing process upon initially enabling the
'Enable Indexation for Autocomplete popup' setting. Otherwise it may result in performance issues in

https://elastic-search-m2.magento-demo.amasty.com/admin/admin/system_config/edit/section/amasty_elastic/
https://elastic-search-m2.magento-demo.amasty.com/admin/admin/system_config/edit/section/amasty_elastic/
https://amasty.com
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the frontend search autocomplete popup and trigger 500 errors in the console.

Please note, that when using the extension with Live Search, the indexation will not work.

Show Related Search Queries in Search Results - this option helps customers to get relevant
results anyway if it's enabled. Choose one mode of the related search results display from the three
available options:

disable ('No, Disabled');
enable permanently ('Yes, Show Always');
enable only for a narrow case ('Yes, Show Only when search returns 0 results').

To learn how to assign related terms, please go to the Related Search Terms part of the guide.

Show Related Search Queries Result Numbers - enable or disable showing related search
queries result numbers.

A front-end sample of tabs:

https://amasty.com/docs/doku.php?id=magento_2:elastic_search#related_search_terms
https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:elastic_search:elastic-searh-m2-tabs.png
https://amasty.com
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Please note that the Related Search Terms counter is displayed only when the default Magento
setting is enabled at Stores → Configuration → Catalog → Catalog → Catalog Search → Show
Results Count for Each Recommendation = Yes.

https://amasty.com
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Replace Empty Search Result Message with CMS Block - Choose 'No' from the dropdown if you
want the zero search results page to remain empty. Or just pick up any CMS block from the list of
your blocks to be displayed in case there are no search results matching the search term.

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:advanced-search:related-terms-counter.png
https://amasty.com
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See an example of how this option can be configured below:

https://amasty.com
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Old Search Requests Auto-Cleaning - Set to 'Yes' in order to clear the data from the
amasty_xsearch_users_search table. Please consider, that Search Analytics, Recent Activity and Most
Wanted reports use this data. Therefore, enabling the auto-cleaning feature can affect analytics.

Auto-Cleaning Period in Days - Here you can specify the period for which you want to auto-clean
the data from the amasty_xsearch_users_search table.

Please note that id the setting 'Enable Fullscreen Mode' is set to 'Yes' then the settings 'Popup Width
(px)' and 'Search Field Width' won't be available.
Please note, that for the correct operation of the module (EE and ECE Magento versions), we do not
recommend using the setting Live Search - Enable Product Listing Widgets=Yes (Admin →
Stores → Configuration → Live Search → Storefront Freatures)

Search Requests Limitation

With the Advanced Search extension, you can block IP addresses that send lots of spam requests.
This helps prevent your databases from cluttering with unnecessary entries. The functionality is
available as part of an active product subscription or support subscription.

Block Requests from One IP Address - set to 'Yes' to enable the option. In such a case The IP
addresses will be blocked according to the conditions set below: exceeding the number of requests
for the specified period of time.

Requests Number - set the number of requests.

Period in Minutes - set the period in minutes.

https://amasty.com
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If more than the specified number of requests were sent from one IP address during the specified
period, then the IP address will be blocked until the set period of time has elapsed since the last
request.

Please note, that for the correct work of this functionality you will need to install the additional library:
GitHub - symfony/rate-limiter, that will provide a Token Bucket implementation to rate limit input and
output in your application.

Search Attributes

You can include any available product attributes in the search algorithm. For each attribute, you can
set a priority (weight).

https://github.com/symfony/rate-limiter
https://amasty.com
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Click Add to create a new attribute. Use the bin icon in the Action column to delete attributes in one
click.

Nuances of Searching by 'Product ID' Attribute

Wildcard and Spell Correction: These features do not work when searching by Product ID.
Weight Setting: We recommend assigning a high weight to this setting.
Minimal Query Length: In Magento search, there is a parameter called “Minimal Query Length,”
which is set to 3 characters by default. This means that for IDs less than 100 (fewer than 3

https://amasty.com
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characters), the search feature will not work. You can configure the Minimal Query Length by
navigating to: Stores → Configuration → Catalog → Catalog → Catalog Search → Minimal Query
Length.

The configuration settings are limited up to 500 attributes. If you have more than 500 attributes
created, please manage them through the Product Attributes grid (Stores → Attributes → Product)

How to set up color attributes for the Magento 2 search extension: use case for making
your Magento quick search more efficient

If there is a color attribute with weight 10 and description attribute with weight 5, and the query is
red, search results will be more visually relevant, because the algorithm will choose color attribute
prior to the words in description. You'll also see in your Magento 2 Advanced search results such
configurable products that have simple ones with the relevant attribute (e.g. like the tee with the
product option 'red color').

https://amasty.com


2025/05/27 06:34 15/58 Guide for Advanced Search for Magento 2

See our Elastic Search for Magento 2 extension that offers a flexible work with a search query and
extensive configuration of product attributes.

Products

Expand this tab to configure products display in a popup window.

https://elastic-search-m2.magento-demo.amasty.com/women/tops-women/hoodies-and-sweatshirts-women.html
https://amasty.com
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Enabled - set to 'Yes' to enable search in products and display search results in the autocomplete
popup.

Pop-Up Display - Choose one of the popup display modes from the dropdown.

* Grid view

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:advanced-search:as-grid-view.png
https://amasty.com
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List view

https://amasty.com
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Title - customize the title for the products block.

Position - specify products block position in the popup. This setting is ignored for the horizontal
popup window.

https://amasty.com
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Max Results - set the max number of displayed results.

Name Length - indicate the max number of characters of a product name that will be displayed in a
popup window.

Short Description Length - set the number of characters for a product short description to be
shown in a search window.

Please note that if you are using the default extension settings, the short description display for a
product will be enabled. If you want to disable it, please specify the 'Short Description Length' as 0
(zero).

Show SKU - Enable this setting to show thee SKU highlighted in the search autocomplete popup.

https://amasty.com
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Show Reviews - Enable reviews display in the autocomplete popup to help customers make the
purchase decision much faster.

Enable 'Add to Cart' button - Set to 'Yes' to show Add to cart button in the popup to let customers
purchase necessary products right away.

Redirect to Product Page - enable this option to redirect in case there is only one search result
available.

Show 'Out of Stock' Products Last - enable this feature to place the out-of-stock items last in
search results. When disabled, these products are displayed according to their relevance.

https://amasty.com
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To make this feature work properly with out-of-stock items being displayed correctly, please make
sure that out-of-stock items' visibility is enabled.

Go to Admin Panel → Stores → Configuration → Catalog → Inventory → Stock Options.
Navigate to a Display Out of Stock Products field → Uncheck Use system value and set to
'Yes'.

Out-of-stock items displayed last in the search results, a sample.

To use and configure Relevance Rules please install the Magento 2 Elastic Search extension first.

Apply Relevance Rules to Autocomplete Popup Results - Set 'Yes' to apply Relevance Rules to
search autocomplete popup results.

Please note that if this setting is enabled, applicable relevance rules (created in Elastic Search
module) will impact not only the search results page, but the search popup as well.

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:elastic_search:elastic-search-m2-out-of-stock.png
https://elastic-search-m2.magento-demo.amasty.com/admin/admin/system_config/edit/section/amasty_elastic/
https://amasty.com
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Multi-Store Search

To adjust the settings for multi-store search please go to Stores → Configuration → Amasty
Extensions → Advanced Search → Products → Multi-Store Search. (Note: this functionality is
available as part of an active product subscription or support subscription)

Enabled - Set to 'Yes' to enable multi-store search.

Stores - Select the stores among which the search will be conducted.

Title - Specify any custom title for the 'Multi-Search' block.

Position - In this field, you can specify the position (display order) of the 'Multi-Search' block within
the search autocomplete popup.

Max Results - Here you can set the maximal number of results from the multi-search that will be
visible in the popup. Or you can just use the system value which is 4 (four).

See the example of how 'Multi-Search' block may look on the frontend:

https://amasty.com
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How to locate the search bar in other places than the default?

By default, the advanced search bar is located at the top right corner of the screen, near the shopping
cart. But using widgets you can overcome Magento limitations and place the search bar anywhere
you need all through the store, like on a sidebar, in the footer, on the CMS pages, and even in
Customer Account.

There are two ways of how to configure some non-trivial location for the search bar:

configure the widget and specify 'Layout Updates';1.
configure the widget, configure a custom block with it, and then use this block (for example,2.
on a CMS page).

For using the first way, please navigate to Content → Widgets and click on the 'Add Widget' button.
Choose the relevant theme to be applied for this widget and the widget type 'Amasty Search Field'.

https://amasty.com
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Specify widget title, needed store views, and the widget sort order.

https://amasty.com
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First, please choose if you want to embed your widget on Categories (anchor or non-anchor),
Products (depending on the product type), or Generic Pages. Depending on that choice you'll see
the available containers for that type of a store page.

As per products and categories you can choose whether to display the widget on all store
product/category pages in bulk or on the specific only.

As per Generic pages, there's the choice from three options, depending on which you'll see the
unique set of the available containers:

All Pages;
Specified Page;
Page Layouts.

When you're ready with all configurations, please refresh the page where you're expecting to see the
widget and try flushing Magento Cache ('System → Cache Management → Flush Magento Cache') to
see the result on the frontend immediately.

For the second way of locating the search bar anywhere else than the default please create the
'Amasty Search Field' widget first and then please go to 'Content → Blocks' to integrate that widget
on some of the existing blocks or for creating new.

https://amasty.com
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See the example of how this widget looks on the frontend (sidebar category menu):

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:advanced-search:advanced-search-m2-sidebar-1.png
https://amasty.com
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Additional Blocks

Extend the search popup with additional sections.

Popular Searches

https://amasty.com
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Enabled - enable the display of the Popular Searches block.

Show on First Click - set the option to Yes to let customers see the Popular Searches block in the
autocomplete popup once they click on the quick search field.

A sample

Title - specify the title of the block.

Position - set the position for the Popular searches block.

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:elastic_search:elastic-search-m2-popular-searches.png
https://amasty.com
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Max Results - set the maximal number of popular search results that will be displayed in the search
autocomplete popup.

Browsing History

Enabled - Set this setting to 'Yes' to allow the logged-in customers to see their latest search queries
in the autocomplete popup.

Please note that this option ('Browsing History' display) is available for the registered (logged-in)
customers only.

Show on First Click - Set this option to 'Yes' to enable showing the 'Browsing History' block at the
first user's click in a popup.

Title - In this field, you can specify any custom title for the 'Browsing History' block.

Position - In this field, you can specify the position (display order) of the 'Browsing History' block
within the search autocomplete popup.

Max Results - Here you can set the maximal number of results from the browsing history that will be
visible in the popup. Or you can just use the system value which is 4 (four).

Please find below the samples of how the 'Browsing History' block can look like on the frontend:

https://amasty.com
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Recent Searches

https://amasty.com
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Enabled - select Yes to display the Recent Searches block.

Show on First Click - set the option to Yes to let customers see the Recent Searches block in the
autocomplete popup once they click on the quick search field.

Specify the Title, Position and Max Results to be displayed.

Display Recent Searches in a pop-up

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:elastic_search:elastic-search-m2-recent-1.png
https://amasty.com
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Blog

Enabled - set to Yes to enable search by blog pages and to display a blog section in the search
window popup to help store visitors find the required content throughout your corporate blog.

Allows to search by blog pages created with Amasty Blog Pro extension.

Title - input a name for the section in the search popup, where the blog results will be displayed.

https://blog-pro-m2.magento-demo.amasty.com/blog/category/articles.html
https://amasty.com


Last update: 2025/05/21 14:35 magento_2:advanced_search https://amasty.com/docs/doku.php?id=magento_2:advanced_search

Also specify the Position, Max Results.

Set Content Heading Length and Content Length to be displayed to make your search
autocomplete window look informative and clear.

Brands

Enable to display a Brand section in the search window popup.

The option allows to search by brand pages created with Amasty's Improved Layered Navigation
and Shop by Brand extensions.

Specify the Title, Position, Max Results, Content Heading Length and Content Length for
Brands block.

Categories

https://lite-layered-navigation-m2.magento-demo.amasty.com/women/tops-women/hoodies-and-sweatshirts-women.html
https://shop-by-brand-m2.magento-demo.amasty.com/brands
https://amasty.com
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Enable the option to let the extension search among category attributes and display the results in
the autocomplete popup.

Specify Categories block Title, Position and the max number of displayed Results.

Name Length - indicate the number of characters of a category title that will be displayed in a popup
window.

Description Length - set the number of characters for a product short description to be shown.

Display Full Category Path - set to Yes to show the full path to the results displayed in the popup.

When mouse hover over a category link, the directory levels are displayed.

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:elastic_search:elastic-search-m2-category-path.png
https://amasty.com


Last update: 2025/05/21 14:35 magento_2:advanced_search https://amasty.com/docs/doku.php?id=magento_2:advanced_search

Exclude Categories - here you can select the categories that you want to exclude from the search
via the popup.

CMS Pages

Enable search on CMS pages to provide customers with detailed search results.

Specify the Title, Position and the Max Results.

Also, set the maximal number of characters for Content Heading and Content that will be shown.

https://amasty.com
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Excluded Pages - Select certain (or all) CMS pages from the list to exclude them from search result
sources. These pages will not be searchable in the popup.

Recently Viewed

Enabled - Set 'Yes' to enable the 'Recently Viewed' widget in the autocomplete popup.

Title - In this field, you can specify a custom title for the widget.

Max Results - Here you can specify the max number of products to be displayed in the slider.

Please note that the 'Recently Viewed' widget (in a form of a slider with recently viewed products) will
be displayed only till the moment a user starts typing.

Bestsellers

https://amasty.com
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Please note that this widget will work only if the Improved Sorting for Magento 2 by Amasty
extension is also installed.

Enabled - Set 'Yes' to enable the 'Bestsellers' widget in the autocomplete popup.

Title - In this field, you can specify a custom title for the widget.

Position - If the widget 'Recently Viewed' is enabled, you can specify in which order these two
widgets will be displayed (which one first).

Max Results - Here you can specify the max number of products to be displayed in the slider.

Please note that the 'Bestsellers' widget (in a form of a slider with recently viewed products) will be
displayed only till the moment a user starts typing.
See how the widgets 'Recently Viewed' and 'Bestsellers' look like on the frontend:

https://improved-sorting-m2.magento-demo.amasty.com/men/tops-men/tees-men.html
https://amasty.com
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Landing Pages

https://amasty.com
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Enable search landing pages in the popup, specify the Title, Position and the Max Results. Set the
maximal number of characters for Content Heading and Content that will be shown in the search
popup.

Allows to search by landing pages created with Amasty Landing Pages extension.
Search Landing Pages

To display Landing Pages instead of the search results page, go to Admin Panel → Marketing →
SEO & Search → Search Terms → Press Add New Search Term.

Input expected Search Query;
Specify the Store;
Redirect URL - input the URL of the landing page.

https://landing-pages-m2.magento-demo.amasty.com/index.php/exercise_kit
https://amasty.com
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FAQ Question

Enable search FAQ pages in the popup, specify the Title, Position and the Max Results. Set the
maximal number of characters for Content Heading and Content that will be shown in the search
popup.

Compatibility with Store Locator

The Advanced Search extension is compatible with our Store Locator extension (the compatibility is
available as a part of an active product subscription or support subscription). This means that if you
have both modules installed, you can also search by store locations created with Amasty Store
Locator extension.

For the functionality correct operation you will additionally need to install the 'amasty/module-store-
locator-advanced-search' package, you can find it in amasty/xsearch module composer suggest.

Navigate to Advanced Search extension general settings to enable the compatibility.

https://amasty.com
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Enable search by Store Locations in the popup, specify the Title, Position and the Max Results. Set
the maximal number of characters for Content Heading and Content that will be shown in the
search popup.

Here's an example of how this functionality may appear on the fronten:

https://amasty.com
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After clicking on a specific store in the search popup, the customer will be redirected to the page of
that store's location.

Compatibility with Improved Sorting

The Advanced Search extension is compatible with Amasty Improved Sorting module. This means that
if you have both modules installed, the sorting of search results in the Search Popup can be
configured according to the settings of Default Sorting on Search Pages. To enable this functionality
please navigate to Amasty → Improved Sorting → Configuration → Sorting by Default →
Default Sorting on Search Pages:

Use in Search Popup - If enabled, products in the Amasty Advanced Search popup will follow the
default sorting configured for search pages. Otherwise, products will be sorted by relevance.

The compatibility of Advanced Search with Improved Sorting also enables the display of Bestsellers
widget in the autocomplete popup.

https://amasty.com
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Custom Layout

Enable this option to customize popup design.

Set colors for a Border, Hover, Highlight, Background, Text and Hover Text using convenient
color picker tool.

See custom layout example:

https://amasty.com/docs/lib/exe/fetch.php?media=magento_2:elastic_search:3-3-ds.png
https://amasty.com
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We have added the ability to delete data from our amasty_xsearch_users_search table, as it can
become very large over time. This is implemented by adding our key to the search_query Magento
table, so that when it is cleared, our table is also cleared. Both tables have a query_id column. And as
soon as the particular ID is deleted from Magento table, the records with the same query_id are
deleted in our table as well.

Analytical Dashboard

The Advanced Search extension allows to maximize profits by analyzing visitors' searching activity
and the data gained.

To see the Search Analytics dashboards, go to Admin Panel → Reports → Search Analytics.

https://amasty.com
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Here you can see the following values: total searches, unique searches, the number of users and
users’ engagement. The Engagement statistics includes the page jumps to Brands, Categories, Blog,
CMS & Landing pages.

Easily check customers’ demand in the Most Wanted Search Terms and Recent Activity blocks.
The extension automatically records the activity of users on the front end and converts it into reports
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on the back end.

Also in this report you can filter information by a specific period of time.

To see more details on Most Wanted Search Terms, go to Admin Panel → Reports → Most Wanted.

Please note that the Engagement metric is about the engagement with the autocomplete popup of
the extension only, i.e. if shoppers click on the links in a popup, add products to cart etc. If they just
type a search term and press 'Enter' without any extra popup engagement, then such action will not
be counted in the engagement stats.

In this report, you can explore the most popular search queries, total searches of terms, the number
of users who were searching for particular terms and engagement level. You can also filter the Most
Wanted Search Terms report by date.

To see more details on customers' Recent Activities, go to Admin Panel → Reports → Recent
Activity.
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Related Search Terms

This extension lets store admins construct a seamless search flow with the related search terms. It is
highly useful for customers, as it helps to navigate the store with relevant search suggestions.

Start by overseeing all search terms, that users created in the store by organically entering search
requests in the autocomplete search window. To access it, please go to the Admin Panel → Reports
→ Search Terms.

Here, you can see how each search word performs. You can also export it in the CSV or Excel XML
formats just in one click. Also, easily add new search terms or edit them.

Press on the required search term to modify it.
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Here, the admin can adjust the general information and assign related terms.

Search Query - enter the search request a user needs to type into the search field.

Store - assign the store view for a specific keyword.

Number of Results - it specifies, how many search results will be returned.

Number of Uses - this number signifies how many times visitors have requested this specific search
query.
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Redirect URL - enter the URL you want to redirect users to when clicking on search results.

Display in Suggested Terms - set to Yes to show this search word in the Related Terms list for
other search requests.

In the Related Terms table you'll get a list of all search terms that are enabled for display in
suggested terms. Mark the necessary ones that match your goal by ticking the checkmark. This way,
it will be much easier for a customer to navigate your store even if they've misspelled the search
requests. Also, it's a great opportunity for a store owner to promote relevant searches that might be
interesting for a customer and therefore motivate them to purchase in your store.

Magento Commerce and the Multiple Wishlist extension
compatibility
The Magento Commerce version of this extension provides some extra opportunities for the wishlist
management in cooperation with the Magento 2 Multiple Wishlist extension.

Provide customers with the ability to choose the wishlist where to save the product, right from the
autocomplete popup.

https://multiple-wishlist-m2.magento-demo.amasty.com/mwishlist/index/index/
https://amasty.com
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Index Management

To reindex categories for correct search results, go to System → Tools → Index Management
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Frontend Samples
Enhance search results pop-up with additional sections. Display the ‘Add to Cart’ button and ‘View All’
link right in a search pop-up window.
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Add handy search tabs to sort and easily navigate the results. Display related search terms in the
search results to encourage users to search more.
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Display the most popular and recent search results right on the first click by the customer.
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The extension package contains MFTF tests aimed at quality and stability enhancement.
Advanced Search for Magento 2 extension is compatible with the built-in Magento EE Sorl & Elastic
Search and AJAX Shopping Cart for Magento 2.

Additional packages (provided in composer suggestions)

To make additional functionality available, please install the suggested packages you may need.

Available for Basic, Pro and Premium tariff plans with no additional fees:

amasty/module-elastic-search - Install module-elastic-search-graphql module to activate
Graphql and Elastic Search.

Available as a part of an active product subscription or support subscription:

amasty/module-elastic-search-graphql - Install amasty/module-elastic-search-graphql
module to activate Graphql and Advanced Search integration.

For Basic, Pro and Premium versions:

https://elastic-search-m2.magento-demo.amasty.com/women/tops-women/hoodies-and-sweatshirts-women.html
https://elastic-search-m2.magento-demo.amasty.com/women/tops-women/hoodies-and-sweatshirts-women.html
https://ajax-shopping-cart-m2.magento-demo.amasty.com/men/tops-men/jackets-men.html
https://amasty.com
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amasty/module-xsearch-hyva-compatibility - Install this package to insure
Autocomplite popup works with Hyva Theme.

amasty/module-search-rate-limiter - Install this package in order to use the DDos
guard functionality.

amasty/module-advanced-search-subscription-functionality - Install this package
to set up the exclusion of categories from display in the search popup, add the ability to filter
reports by date using the From - To functionality and search using the Product ID.

amasty/module-advanced-search-multi-store - Install this package for Multi-Store
Search compatibility.

PWA for Elastic Search (Add-On)

Provide shoppers with an outstanding cross-device experience by implementing a ready-made PWA
solution to your store. Allow customers to smoothly search and quickly find what they need using the
Elastic Search extension in a combination with the PWA add-on.

Please note that the PWA add-on will work correctly only if a PWA theme and the original Elastic
Search extension for Magento 2 are installed to your store. Learn more on how to install PWA
Studio here.

If the add-on is installed, the autocomplete popup of the Elastic Search extension will look on Venia
the following way:

Please note that colors of the autocomplete popup on the screen below are customized through the
feature 'Custom Layout' and it is not the default look.

https://amasty.com/docs/doku.php?id=magento_2:pwa_installation_user_guide
https://amasty.com/docs/doku.php?id=magento_2:pwa_installation_user_guide
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This very PWA add-on does not support the following features of the original extension:

ability to add searchbars via widget;
show search results from the compatible to the original Elastic Search extensions: Blog Pro,

https://amasty.com
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Shop by Brand, Landing Pages, FAQ & Product Questions.

Find out more about Magento PWA integration here.

Find out how to install the Advanced Search extension for Magento 2 via Composer.

From:
https://amasty.com/docs/ - Amasty Extensions FAQ

Permanent link:
https://amasty.com/docs/doku.php?id=magento_2:advanced_search

Last update: 2025/05/21 14:35

https://amasty.com/blog/how-to-create-pwa-storefront-using-magento-2-pwa-studio/
https://amasty.com/docs/doku.php?id=magento_2:composer_user_guide
https://amasty.com/docs/
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