


Last update: 2025/06/23 10:54 magento_2:b2b_ecommerce_suite https://amasty.com/docs/doku.php?id=magento_2:b2b_ecommerce_suite

For more details see the B2B E-commerce Solution extension page.

Guide for B2B E-commerce Solution for
Magento 2

Optimize your e-commerce operations with our all-in-one B2B solution, tailored to the specific needs
of modern B2B markets. Fully compatible with Adobe Commerce B2B, this solution provides a range
of practical features that help your business adapt to shifting e-commerce trends and manage both

B2B and B2C activities efficiently.

e Let companies create multiple accounts

e Create a structured dealers base

e Customize pricing policy per customer group
e Set precise access limitations

¢ Let buyers negotiate prices using quotes

e Streamline bulk ordering

e Grant store credits as incentives

¢ Build an automatic discount system

Enable smart product recommendations
Optimize shipping & payment operations
Hyva-ready storefront and Hyva Checkout compatible
REST API support

We've crafted three tailored B2B solutions to advance your business. Each feature is designed for
seamless integration with each other and native Magento 2. Select the option that aligns with your
business objectives, whether you're starting from scratch, enhancing your existing website with extra
features, or transforming your B2C site into a fully functioning B2B or B2B2C platform.

B2B E-commerce Essentials Solution for Magento 2

This solution is built to empower your store with the most essential features to upgrade your B2C
Magento store and make it ready for working in the B2B segment.
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All the basics for starting

B2B business

B2B Company Account

Quuick Order

Customer Group Auto Assign
Extended Product Grid with Editor
Product Attachments

Google Account Login

Color Swatches Pro

B2B Company Account

Simplify purchases for your customers by introducing B2B Company Accounts to Magento 2 store. Let
companies register multiple user accounts, allow special permissions to enhance the shopping, and
get more orders.

e Create multiple company accounts as a store admin;

¢ Allow businesses to create and manage sub-accounts from the frontend,;

e Transfer users between company accounts in the backend;

e Easily manage all company accounts in one place;

 Offer personalized marketing and pricing based on company membership.
e REST API Support

Navigate to Stores -» Configuration - Amasty Extensions - Company Account.
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Company Account 1.0.0 by amasty

© Need help with the settings? Please consult the user guide to configure the extension properly.

General

Allow Company Creation for
Customer Group(s) Big Whale Development LTD

Business Company
Example Company LLC
General

Retailer

Small companies
Wholesale

¥

Approve Companies Automatically |,

If set to es, all new companies will automatically get
ACtive status.

Inactivate Customer upon Removing

Yes v
from Company Account

if disabled, the customer will still remain Active after
being remaoved from Company in admin panel. Note:
you can change Customer's Status on Customer edit

page.

See detailed configuration guide here.

Quick Order

For B2B sales it's important to provide options for convenient bulk purchasing without visiting each
product page every time. With this solution it is possible with the Quick Order page.

Key features:

e Let clients add products by SKU/Name

e Create orders by inserting multiple SKUs

e Import products for orders via CSV and XML files
 Allow buyers to specify custom product options
 Allow placing quick orders from the category pages
e Provide convenient quick order UX on mobile

To enable the functionality, proceed to Stores - Configuration - Amasty Extensions - Quick
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Order.
General
Enabled .
[store view] Yes v
URL K :
i :'.j’f' guick-order
Based on Website Base URL If left empty. default ‘guick-order” is used.
Label
fetors view] Quick Order
Here you can name the functionality the way you would like it to be displayed on the
storefront. If left empty, default Quick Order is used.
Display Link in
[store view] Page Header
Top Menu
Page Footer
e
Choose where to display a link.
Disable for Customer Groups
[store view] Mot Logged In
Genera
Retailer
Whaolesale
S

Chosen customer groups won't be able to Quick Order.

See detailed configuration guide here.

Customer Group Auto Assign

This Magento B2B solution allows you to utilize a smart algorithm to automatically categorize
customers into groups applying different pricing levels for different customer groups.

Key features:

Manage customer groups based on custom rules

Use simple rules based on customer and order attributes

Schedule the rules processing frequency with integrated Cron functionality
Define rules processing order via prioritization

Easily manage all group-switching rules in one place

Show customer group status in the customer's account

To adjust the rules for automatic assigning of customer groups, proceed to Customers - Amasty
Customer Group Auto Assign - Rules.
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RU|ES A demouser ~
Add New Rule
Y Filters
Actions - 5 records found 20 * | per page 1 of 1

Destination

Rule Name Group Priority | Status
Switch to "10% discount” group (Mumber of completed orders = 5) 10% discount 1 ENABLED Edit
Switch to "20% discount” group (number of completed orders > 13) 20% discount 1 ENABLED Edit
- P— . . VIFP (30%
Switch to "VIP" group (number of completed orders = 30) discount) 1 ENABLED Edit
- - A . _ ' . Lifetime -

Switch to "Lifetime customers” group {customers since at least 2010-01-01) CUSLOITIETS 1 EMABLED Edit
Switch to "Sports facilities” (number of products ordered from Gear/Fitness - )

Sports facilities 2 ENABLED Edit

equipment category )

See detailed configuration guide here.

Extended Product Grid with Editor

This module will enable you to monitor, filter, and modify any catalog info right from the grid to
minimize time spent on catalog processing: add columns, edit data in the cells, and even manage the
product inventory. Moreover, you can create templates to save the desired grid layouts and switch
between them according to your needs.

Key features:

e Edit product data right on the grid

¢ Activate additional product attributes

e Add product grid templates

e Manage product inventory by adding or deducting items
e Customize filters to easily find information

e Compatibility with Magento Enterprise splitted databases

To configure general extension settings please go to Stores - Configuration - Amasty
Extensions - Product Grid.
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Editing Settings

Editing MO'-LE Multi Cell .

Single Cell - data is being saved right after any cell is edited.
Multi Cell - 5ave button should be clicked after data in multiple
cells has been edited.

Crop Decimal Digits

[ZloDal]

No -

When enabled, decimal digits in the grid are cropped to 2
decimal places and rounded.

Additional Grid Columns Settings
(~) Related products, Up-sells, Cross-sells Columns

(=) 'Qty Sold' Column

Quantity Based Availability

Quantity Based Availability

L Ll §

es *

When set to yes, availability will automatically change to 'In
stock’ when quantity is positive and to 'Out of stock” when
quantity is zero or negative. When set to "No', availability status
will not be updated automatically.

See detailed configuration guide here.

Product Attachments

Offer customers additional product info: provide accurate manuals, licenses, warranties and other
documents on webstore pages.

Key features:

e Upload the unlimited number of attachments

e Support for any file types

e Track attachments downloads

e Equip files with catchy icons

e Compatibility with the Magento Enterprise Remote Storage functionality
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To configure general extension settings please go to Stores —» Configuration - Amasty
Extensions - Product Attachments.

General =)
Enable Module
rstore view] fes -
Add Category Files to Pmdu-its Yes ~ @
Display “Include In Order”
Files on Product Pages and Mo -

Widgets

Url Creation Type id
ID type URL: hitpo/fdomain.zone/amfile/download /file/22. Hash type URL:
httpo/fdomain.zone/amfile/download file/Ba9el7bad (1664380006429 b235cade

Links Accessibility Check =)
Check Linked Product )
Attachments Accessibility | -

Product Tab =)

Show "Product Attachments” Yes -

Tab
storeview] A new tab with product attachments will be added
to product tabs on a Product Page

-[El.t?.nfl,ef Product Attachments

See detailed configuration guide here.

Color Swatches Pro

With the extension, you can display prices in handy swatches, enable image flippers, zoom, configure
preselect options, etc.

Key features:
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e Enable product matrix

e Show prices of simple products

e Swap product image on mouse hover

¢ Reload product info with AJAX

¢ Allow customers to share URLs with custom product configs

To enable the module and adjust it, go to Stores - Configuration » Amasty extensions - Color
Swatches Pro.
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Configuration

Store View:  Default Confiz » Save Config

Color Swatches Pro 2.7.3 by amaﬁtq

1 AMASTY ~
EXTENSIONS

General &)
Extensions & Motifications

Reloadable Information &)
Color Swatches Pro

Product Matrix >

Google Account Login

Display Last Attribute in

Rows
[store view]

Reguest a Quote For Specified Products v

Display SKU Column
Hide Price Py [store view] | O

Display Available Qty Column

Sales Reps and Dealers [store view] res i
_ Display Subtotal r‘_Cc:!Iumrju Yes -
Store Credit [stare view]
-
Preselect &)
-
Zoom &
i ™
Lightbox &)
-
Carousel &)

See this user guide to see the available configuration options.
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B2B E-commerce Pro Solution for Magento 2

This solution includes all the Magento 2 B2B commerce features from the Essentials, plus extended
functionality for advanced personalization and customer segmentation, catering to the diversified
needs of growing B2B companies.

B2B E-COMMERCE SUITE: PRO

Grow business

better understanding customers' needs

All features from B2B Essentials +
4 Request a Quote

4 Hide Price

4 Store Credit & Refund

4 Sales Reps and Dealers

§4 Customer Group Catalog

¥ Social Login

4 Product Option Templates
4 Cancel Orders

Request a Quote

This functionality will allow you to ceate accurately adjusted pricing offers to the various segments of
your audience. Let buyers comfortably negotiate prices and create quotes in one click from any web
store page.

Key features:

e Let clients request quotes from any page

¢ View and manage all quotes in a separate grid

e Automatically approve quotes with specific conditions
e Let guest visitors ask for quotes

e Easily turn quotes into orders

To enable quote request availability, proceed to Stores - Configuration - Amasty extensions -
Request a Quote.
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General

Enable 'Request a Quote’ |, -
‘Add to Quote' button on Product | __
Show =
~ Page
'Add to Quote’ button on Category Show .
- Page
Disable Quotation for Categories . Gear ‘@
......Bags

...... Fitness Equipment
...... Watches

... Training

‘Add to Quote’ button will be hidden for each product from the selected
categories. This setting is applied to product list and product page.

Allow Quote Request for
Customer Groups
LT Ve General

Mot Logged In
Vholesale
Retailer

f'Mot Logged In' option is chosen, guest users will insert email addresses
upon gquote submission and accounts will be created automatically.

A detailed configuration guide you can find here.

Hide Price

Hide product prices and “Add to cart” button for specific products or whole categories. Manage prices
display depending on customer groups.

Key features:

Limit prices visibility on category and product pages
Disable 'Add to Cart' and 'Add to Wishlist' buttons
Show prices to specific customer groups only
Customize text messages

Redirect clients to any form or page

To configure the module, please go to Stores -» Configuration - Amasty extensions - Hide
Price.
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Configuration

Store View:  Default Config Save Config

Hide Price 1.5.14 by amasty

O AMASTY ~
EXTENSIONS
General Settings ©
Extensions & Motifications
Hide Price Options 2
Color Swatches Pro
Hide Price. | ves -

Google Account Login

Hide "Addto Cart) | ves -

Reguest a Quote ' ]
Hide ‘add to Cart’ or replace it with the
custom button, e.g. “Sign up’ or 'Get a
Quote’

Hide Price

Hide "Add to Wishlist"
[store view]

‘fes -

Sales Reps and Dealers Hide wishlist link when price is hidden

Hide "Add to Compare"

Store Credit rstore view] Yas v

Hide compare link when price is hidden

Frontend Options >
Admin Email Notifications )
Auto Reply Email Options @

Check how to adjust price display for particular products, categories or even customer groups here.

Store Credit & Refund

B2B Suite also includes the solution to improve retention by granting store credits, that clients can
use for further purchases.
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Key features:

e Add or subtract any store credit amount from the admin panel
Let clients spend their credits on new purchases

Process refunds with store credits application

Show store credit and refunds balance in customer account
Send notifications about any changes in balance

To activate the functionality, navigate to Stores —» Configuration - Amasty Extensions - Store
Credit.

Configuration

Store View:  Default Confiz + Save Config

General
€1 AMASTY ~
EXTENSIONS
Enable_-_!ﬂgdl_;ll_g Yec v
Extensions & Motifications
Refund Store [.red|t Yes . 0
Automa‘gcally
Color Swatches Pro [Eioba
Allow applying Store Credit Ves .
~on Ta:-_{ N
Google Account Login [Stare view
Allow applying Store Credit Ves .

on Shipping
Reguest a Quote [store view]

Hide Price Email Notification

Sales Reps and Dealers Elastic Search

Store Credit

Click here to check the configuration for all extension settings.

Sales Reps & Dealers

Provide high-quality service and individual approach to each customer by including dealers in your
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business model.
Key features:

e Create multiple user roles

e Assign orders to particular dealers

e Let clients choose their dealers

e Show dealer information to clients

* Check the list of orders assigned to each dealer
¢ Use notifications to keep sales reps informed

To configure general extension settings, go to Stores - Configuration - Amasty extensions -
Sales Reps and Dealers.
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General

Default DE"“'ET Frank Wilson

[global]

All new orders will be assigned to this dealer except if
specific customer is already assigned to another dealer,

Send New Order Email to the Dealer |, .
[global]
Indicate "Yes' to send a copy of the order email to the

associated dealer.

Show Re-assign Fields

[global]

Yes ¥
On the order view page in Backend.

Show From To

I=zloba
Liulal]

Yes A

From whom to whom re-assigned order.

Show Author of Message

oo | Yes v
Hide the "Manage Customers” tab |, .

On the "Edit User” page (the "Edit Dealer” page).

Allow dealers to see all customers and NO

orders
[globall  Indicate “Yes® to allow dealers to see all customers and
orders in the systam

Check how to adjust each setting in this guide.

Customer Group Catalog

Create an individual selling strategy for your clients by providing a selective catalog and price
visibility for particular customers and customer groups to meet the needs of each segment.
Key features:

¢ Adjust the visibility of products and categories by customer groups
* Provide businesses with selective access to store catalog
¢ Hide or replace product price with CMS-block or image
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e Redirect users to custom CMS-pages or to 404 page

To configure these options, go to Store -» Configuration - Amasty Extensions » Customer
Group Catalog.

General Settings

Enable module

[elobal] Yes v

Email Sender for Admin 'Get
a Quote' Reply Email

[elobal]

General Contact v

Email Template for Admin

'‘Get a Quote' Reply Email
[globall - Email template chosen based on theme

fallback when "Default" option is selected

Amasty 'Get a Quote’ Answer |

Frontend Options

Admin 'Get a Quote' Email Notifications

Auto Reply 'Get a Quote' Email Options

Developer Options

To check detailed guide for the extension, click here.

Social Login

Provide customers with an easy single-click registration and login process via social networks.

Key features:

* AJAX pop-up for the login/register purpose
¢ 4 positions of the social login bar
e Redirect after login
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e Included reCAPTCHA

e Supports Google, Facebook, Twitter, Instagram, LinkedIn, Amazon, Paypal, Twitch, Pinterest,
etc.

e WCAG compliance

To configure these options, go to Store —» Configuration - Amasty Extensions - Social Login.

General Settings

Enable Social Login

Yas v
Set "Yes' to allow login via social networks. 5et "No’ to disable social login

buttons. Note that the AJAX Pop-up can still be applied for standard login
and registration.

Add Social Login to
[store view] Login Popup
Above customer login form
Below customer login form

Above customer registration form
L TP P SN U JULL RPUUPN B SN g — (4

Choose where to place the social login buttons.

Login Buttons Shape Square Buttons ~ @
Enable Ajax Popup No - @

Set "Yes' to activate A)AX Pop-up for the registration and login.

Use New Redirect URI

|shore wiew]

Mo -

Redirect URI will soon be replaced by New Redirect URL To avoid
functioning downtime we strongly recommend to switch to new url
before next extension's update.

Google

Facebook

Click here to explore the detailed configuration guide.

Product Option Templates

Offer extra product customizations and services right on the product pages: add materials info,
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related items and services, price variations, etc.
Key features:

o Offer extra products and services

e Customize options with image, text and color swatches
» Configure smart option dependencies

* Quickly assign option templates to multiple products

¢ Add free and paid accompanying items to products

To create and manage product option templates, go to Catalog - Product Option Templates -
Template List.

Template List L demouser v

Add New Template

W Filters > DefaultView - -ﬁ- Columns

7 records found 20 ¥ | per page 1 of 1

Quantity of Products with the Template

2 Bags Colors [ Select «
3 Bags Size 7 select ¥
4 Watch extra services 9 Select -
5 Gift Box 5 Select v
6 Material 19 select ¥
7 Video guide 1 Select =
9 Delivery 40 Select »

Check how to adjust each setting in this guide.

Cancel Orders

Let clients cancel irrelevant orders in their accounts. Your store admins can also automatically cancel
orders without payments after a specified period.

Key features:

¢ Allow clients to cancel orders in accounts
e Show cancellation popup
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e Collect cancellation reasons

e Track annulation requests

» Notify your managers about new cancellations
e Automatically restock cancelled items

Go to Stores - Configuration - Amasty Extensions -» Cancel Orders.

Cancel Orders 1.0.0 by deStg

P Need help with the settings? Please consult the user guide to configure the extension

properly.
General =
Enabled | ... .
[store view]
Allow for Selected Group(s)
[store view] General
Retailer
Wholesale
s
Allowed Order Status(es) _
[store view] Pending
Processing
Suspected Fraud
i
Refund Paid Processing | 5 i (if possible) .

Orders Automatically
[store view] Disabled

Online (if possible)
Offline

See how to adjust cancellation and set automatic annulation in this guide.

B2B E-commerce Premium Solution for Magento 2

This solution includes all the features from the Essentials and Pro versions, plus extended

amasty


https://amasty.com/docs/doku.php?id=magento_2:cancel_order
https://amasty.com

2025/06/28 14:41 21/27 Guide for B2B E-commerce Solution for Magento 2

functionality to manage targeted promotion campaigns and streamline shipping and payment
operations.

B2B E-COMMERCE SUITE: PREMIUM

Maximize revenue

with smart management

All features from B2B Essentials and Pro +
&4 Special Promotions Pro

Automatic Related Products

£4 Shipping Restrictions

Payment Restrictions

Multiple Wishlist

i Customer Attributes

Special Prommotions Pro

Use 20+ promotion types at your disposal to easily create the offers that resonate with various
segments of your audience.

Key features:

e Create 20+ promotion types for extraordinary deals
e Use customer's attributes as rule conditions

e Limit promotions based on customers' order history
e Select the base price for discount calculation

e Restrict promotions for products with special prices

To configure extension general settings, go to Stores -» Configuration - Amasty Extensions -
Special Promotions Pro.
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General

Check Special Options Values

[store view

Yes v

Skip Settings

© skip options are available for Amasty actions only.

Skip Items with Special Price No

[store view

Skip Items with Tier Price No

[store view

Skip Configurable Items when Child

has SPECIﬂlF’I'IICE Ne ’
Discount Breakdown
Show Discount Breakdn:.'urn Yes .
Debug
Enable Debug Mode |, -

[eloba
e |

Show Debug Information Only For

Izloh
Lgral)

[ RS | & T R R ——

Explore how to adjust other settings and to create promotion rules in this guide.
Automatic Relateed Products

Dynamically showcase related product offers on your website, thus motivating customers to
complement their orders with extra items.

Key features:
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e Use rule-based algorithm to offer related items

Show related products based on history of views or purchases
Display items on any store page

Offer bundle packs with fixed or percentage discount

Create a specified CMS page with all bundles

Monitor related offers efficiency with advanced analytics
Import and Export bundle packs data

To configure extension general settings, go to Stores - Configuration - Amasty Extensions -
Automatic Related Products.

l,-_'\
General )
To configure the rules please go to Catalog -> Amasty Related Products -> Related Product Rules
Data Gathered 10
Period (days)
[store view]  please specify the time period basing on which the module will gather statistical data and display related,
up-selling and cross-selling products for ‘Bought together' and "Viewed together’ condition.
Order Statuses
[store view] -- Please Select --
Pending
-
Processing
o
Please specify the order statuses that needs to be considered when the system selects matching products
for 'Bought together' condition.
Ignore Anchor
g 1O | No =
Categories in
'Same As' If enabled, the rule condition 'Category is same as Current Product Categories' will consider only non-
Condition &@nchorcategories the product belongs to.
[store wiew]
Enable Products
Displaying of | Mo v
Subsequent Rules
[global]
Display Multiple No -
Related Products
Blocks Setto 'Yes' to display multiple blocks of related products.
[store view]
Py
Bundle Packs >

Product Tab -

|Store v

Display Position

Explore how to create related offers rules as well as bundle pack offers in this guide.
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Shipping Restrictions

Also, you may use shipping options as a special benefit for your clients. Enable particular methods for
any of them using restrictions for others.

Key features:

 Define a specific area of each shipping method application

e Restrict shipping methods of particular carriers

e Offer shipping methods depending on their purchase history

e Choose the kind of orders, to which shipping restriction rules should be applied
¢ Assign special shipping methods to specific stores and customer groups

To adjust methods, please go to Sales - Operations - Shipping Restrictions.

Shipping Restrictions A cemouser +
Add Rule
Y Filters G Default View £ Columns v
Actions - 2 records found 20 ¥  per page 1 of 1
Gm.lps Views
tive For Canada DHL [dhl] Rest All Store Select
Federal Express [fedex] All Views

Flat Rate _"’Ia:ra'.E'_

Best Way [tablerate]

Free Shipping
[freeshipping]

United Parcel Service [ups]
United States Postal Service

|UsSps)

i Active  Free Shipping for Free Shipping Any NOT All Store Select
Wholesalers [freeshipping] LOGGED IN Views
Genera
Retailer

Check advanced configuration cases here.
Payment Restrictions
The suite includes options that limit payment methods availability according to specific parameters. It

means that you can let particular methods for specific customer groups only, e.g. offline methods will
be available for long-term clients and won't be visible for guests.
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Key features:

Set restrictions based on cart contents

Apply restrictions depending on customer shipping address

Use customer purchase history to decide which payment methods to show

Display different payment methods for orders depending on Subtotal or customer attributes

To create limitation rules, please go to Sales -» Operations - Payment Restrictions.

Payment Restrictions

l gemouser =

Add Rule

¥ rilters ©» DefaultView = £ Columns =

Actions v 2 records found 20 ¥  perpage

BB | Status  Name

Active  Offline Offline - Bank Transfer Payment, Offline - Cash On Delivery,
Payments Offline - Check / Money order, Offline - Mo Payment Information
for Required, Offline - Purchase Crder

Wholesales

Active  PayPal for Paypal - Credit Card (Payflow Advanced), Paypal - Credit Card

Wholesalers  (Payflow Link), Paypal - Credit Card (Payflow Pro), Paypal - PayPal
Billing Agreement, Paypal - PayPal Credit (Payflow Express Bmi),
Paypal - PayPal Credit (Paypal Express Bmil), Paypal - PayPal
Express Checkout, Paypal - PayPal Express Checkout Payflow
Edition, Paypal - Payment by cards or by PayPal account, Paypal -

View configuration details in this guide.

Multiple Wishlists

General
Retailer

Restricis
For All

Default Duplicate
Store
Wiew
Default Duplicate
Store
Wiew

Enable customers to plan their purchases in advance. Allow companies to create unlimited wishlists

and requisition lists to store products they need.

Key features:

e Present multiple wishlists and requisition lists in customer accounts

e Convert wishlists to orders with the ‘Add to Cart’ button
e Mar lists with comments and notes

e Add products to wishlists by SKU or product name

¢ Analyze client demands with the wishlist report
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To activate the functionality, go to Stores - Configuration - Amasty Extensions -» Multiple
Wishlist.

Multiple Wishlist 1.0.0 by amasty

o Need help with the settings? Please consult the user guide to configure the extension

properly.

General =

Enatied [ ves '

See the frontend examples and configuration here.

Customer Attributes

The B2B Solution Premium includes the Customer Attributes module, enabling you to display
additional attribute fields on the checkout and registration pages to collect essential customer data.
Create various types of customer attributes to gather all the information you need. Use this data to
analyze customer behavior and gain valuable insights to enhance your store's performance.

Key features:

e Show extra attributes of different input types
Manage customer attributes from the admin panel
Effectively process collected customer data

Use additional attributes in email templates
Generate handy attribute usage reports

WCAG compliance (for Hyva Theme)

To activate the functionality, go to Stores - Configuration - Amasty Extensions -» Customer
Attributes.

To create and manage customer attributes please go to Customers —» Customer Attributes -
Manage Attributes.
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Customer Attributes

Reset Filter 5 records found

Show on the Show on Show on the
Customers the Orders | Order View
Grid Grid page
v v ¥ T
affiliate_program Whould you like Yes/MNo 4 Yes Yes Yes
to join an affiliate
program?
company_name What is your Text Field 2 s Yes Yes
company name?
company_position Your position in Text Field 3 Yes Yes Yes
the company
customer_group Choose your Dropdown 1 Yes Yes Yes
customer group

View all configuration details in this guide.
When all options are properly configured, your store will be 100% ready for a successful B2B model.
Just choose your own strategy to make your business maximally profitable.

Find out how to install the B2B Solution for Magento 2 via Composer.
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